A considered way to shop. Discover · Compare · Choose
The shop directory ↗
Home›More products›TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch
TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch
A LITTLE COMPARISON GOES A LONG WAY

TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch

Explore TP-LINK →
LOWEST LISTED PRODUCT PRICE
£250.49

at Gotraka · 1 shop

Listed delivery: £0.00 · Total £250.49

Visit best offer Affiliate link · Buy directly from the retailer
Compare all 1 offers ↓

Price data received 06 Nov 2026 20:36

COMPARE BEFORE YOU CHOOSE

Prices & shops

1 shop

Sorted by product price. Delivery is shown separately and may depend on your address, delivery method and basket.

GotrakaLowest product price · Reported in stockListed delivery: £0.00 · Total £250.49Price data received 06 Nov 2026 20:36
£250.49
View offer ↗

We show offers from partner shops. Confirm the final price and availability with the retailer before ordering.

THE FINER DETAILS

Product details

TP-Link Omada 8-Port 10GE SFP+ L2+ Managed Switch. Switch type: Managed, Switch layer: L2/L3. Console port: RJ-45/micro-USB. MAC address table: 32000 entries, Switching capacity: 160 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1s, IEEE 802.1w, IEEE 802.3ad, IEEE 802.3x. Power connector: DC-in jack. Rack mounting

TP-Link | Omada L2+ managed switches provide high performance, powerful L2 and L2+ features like static routing, enterprise-level QoS, advanced security strategies and a bundle of ISP features. The 10-gigabit ports ensure high-speed data transfer, and their backward compatility with gigabit products reserves room for network upgrades, therefore guarantees stable and long-term usability. The IP-MAC-Port Binding (IMPB) and Access Control List (ACL) functions protect against broadcast storm, ARP and Denial-of-Service (DoS) attacks, etc. Quality of Service (QoS, L2 to L4) provides enhanced traffic management capabilities to move your data smoother and faster. The OAM function helps facilitate network management. Moreover, the easy-to-use web management interfaces, along with CLI, SNMP and Dual Image mean faster setup and configuration with less downtime. TP-Link | Omada L2+ 10-gigabit managed switches provide a reliable, secure solution for enterprise, campus and ISP networks.

3 year limited warranty for normal product and 5 year warranty for managed switch

Management features


Switch type
Managed


Switch layer
L2/L3


Quality of Service (QoS) support
Yes


Cloud-managed
Yes


Web-based management
Yes


Traffic classification
Yes


Configuring Location Settings (CLI)
Yes


ARP inspection
Yes


System event log
Yes


MIB support
RFC2925, RFC2618, RFC2620, RFC2021, RFC2819, RFC2674, RFC1493, RFC1643, RFC2233, RFC1213



Ports & interfaces


Basic switching RJ-45 Ethernet ports quantity
1


Basic switching RJ-45 Ethernet ports type
No


Installed SFP modules quantity
8


SFP+ module slots quantity
8


Console port
RJ-45/micro-USB


Power connector
DC-in jack



Network


Networking standards
IEEE 802.1D, IEEE 802.1Q, IEEE 802.1s, IEEE 802.1w, IEEE 802.3ad, IEEE 802.3x


10G support
Yes


Port mirroring
Yes


IP routing
Yes


Rate limiting
Yes


Head-of-line (HOL) blocking
Yes


Spanning tree protocol
Yes


Link aggregation
Yes


Broadcast storm control
Yes


Flow control support
Yes


VLAN support
Yes


Virtual LAN features
Private VLAN, Protocol-based VLAN, Voice VLAN


Number of VLANs
4000



Data transmission


MAC address table
32000 entries


Switching capacity
160 Gbit/s


Forwarding rate
119.04 Mpps


Number of queues
8


Static route
Yes


Jumbo frames support
Yes


Jumbo frames
9000


Packet buffer memory
16 MB



Security


DHCP features
DHCP relay, DHCP server, DHCP snooping, DHCPv6 client, DHCPv6 snooping


Access Control List (ACL)
Yes


IGMP snooping
Yes


IP-MAC-Port binding
Yes


BPDU filtering/protection
Yes


Loop protection
Yes


Authentication
Guest VLAN, MAC-based authentication, Port-based authentication, Web-based authentication


Queue scheduling algorithms
SP, WRR+SP, Weighted Round Robin (WRR)


Static port security
Yes


SSH/SSL support
Yes


MAC address filtering
Yes


Authentication type
AAA, TACACS+


Security algorithms
HTTPS, SSH, SSH-2, SSL/TLS



Multicast features


Multicast support
Yes


Multicast Listener Discovery (MLD) snooping
Y



Protocols


Management protocols
SNMPv1/v2c/v3, SNTP


IPv4 & IPv6 features
IPv6 Telnet, IPv6 ping, IPv6 tracert



Design


Rack mounting
Yes


Stackable
No


Product colour
Black


LED indicators
Yes


Certification
CE, FCC



General

Product family
Omada


Power


Power source
AC


Power supply included
No


AC input voltage
220 V


AC input frequency
50/60 Hz


Power consumption (max)
15.46 W



Power over Ethernet (PoE)

Power over Ethernet (PoE)
No


Operational conditions


Operating temperature (T-T)
0 - 45 °C


Storage temperature (T-T)
-40 - 70 °C


Operating relative humidity (H-H)
10 - 90%


Storage relative humidity (H-H)
5 - 90%


Heat dissipation
52.75 BTU/h



Weight & dimensions


Width
440 mm


Depth
180 mm


Height
44 mm



Packaging data


Cables included
AC


Quick start guide
Yes


Rack mount kit
Yes


Package type
Box


Manual
Yes
Brand
TP-LINK

Maybe also: